Your WhiteNoise configuration is incompatible with WhiteNoise v4.0 1

Your WhiteNoise configuration is incompatible with WhiteNoise v4.0

#In the wsgi.py file use
from whitenoise import WhiteNoise

application = WhiteNoise(get_wsgi_application())

Here is what the above code is Doing:
1. We import the WhiteNoise class from the whitenoise package.
2. We wrap our existing WSGI application in the WhiteNoise class.
3. We set the static files directory to be the staticfiles directory.
4. We set the static files directory to be the staticfiles directory.
5. We set the root directory of the static files directory to be the staticfiles directory.
6. We set the index file to be index.html.
7. We set the autorefresh option to True.

Similar Posts